Не решено - Авто апдейт в Майнкрафт

Не решено Авто апдейт

GODIMONGO

Клиент
Клиент
Рубли
3.0
Как мы понимаем обновление плагинов это давольно затратный процесс по времени. Советую сделать функционал автообновления плагинов как это сделано у многих аналов. Так же сделать возможность установить обновления самому когда тебе захочется а не принужать пользователя
 
Так же хотелось бы что бы добавили:
список плагинов от которых зависит основной плагин условно mcregion требует utilm такой то версии это займет всего пару минут времени разработчика но на сайте сразу будет версия и будет все ясно. Так же хотелось что бы mcregion имел поддержку блоков для привата которые игрок не может раскрафтить то есть ты выдал с помощью команды блок и все игрок не может раскрафтить блок и только поставить либо сломать. Хотелось бы видеть авто апдейты всех плагинов с помощью команды. хотелось бы видеть вомзожность с помощью команды проверить последнюю версию, что бы плагин не умирал если он устарел еще возможность в чат высвечивать администратору сообщение о том что плагин устарел, добавить уведомления на почту телеграм и тд о том что плагин обновился.
 
Так же хотелось бы что бы добавили:
список плагинов от которых зависит основной плагин условно mcregion требует utilm такой то версии это займет всего пару минут времени разработчика но на сайте сразу будет версия и будет все ясно. Так же хотелось что бы mcregion имел поддержку блоков для привата которые игрок не может раскрафтить то есть ты выдал с помощью команды блок и все игрок не может раскрафтить блок и только поставить либо сломать. Хотелось бы видеть авто апдейты всех плагинов с помощью команды. хотелось бы видеть вомзожность с помощью команды проверить последнюю версию, что бы плагин не умирал если он устарел еще возможность в чат высвечивать администратору сообщение о том что плагин устарел, добавить уведомления на почту телеграм и тд о том что плагин обновился.
 

Вложения

  • Screen Shot 2024-06-12 at 2.35.17 PM.png
    Screen Shot 2024-06-12 at 2.35.17 PM.png
    18.3 KB · Показов: 5
  • Screen Shot 2024-06-12 at 2.34.07 PM.png
    Screen Shot 2024-06-12 at 2.34.07 PM.png
    29.4 KB · Показов: 5
Вы каждый раз предлагаете мне залезать в конфиг? Вы лазете после каждого обновления плагина во все конфиги? А если плагинов 40 штук? Замечу что если версия utilm не подходит к сожалению плагин не запускается в следстии чего конфиг так же не меняется и там не указывается требуемая версия так что считаю совет не корректным.
 
Последнее редактирование:
# Зависимости: (плагины без которых этот работать не будет)
# - UtilM Ссылка скрыта, пожалуйста Войдите или Зарегистрируйтесь (utilm-x.x.x-jar-with-dependencies.jar)
# - DecentHolograms: Ссылка скрыта, пожалуйста Войдите или Зарегистрируйтесь (опционально на выбор)
# - HolographicDisplays: Ссылка скрыта, пожалуйста Войдите или Зарегистрируйтесь (опционально на выбор)
не вижу тут конкретной версии utilm для последней версии
 
Вы каждый раз предлагаете мне залезать в конфиг? Вы лазете после каждого обновления плагина во все конфиги? А если плагинов 40 штук? Замечу что если версия utilm не подходит к сожалению плагин не запускается в следстии чего конфиг так же не меняется и там не указывается требуемая версия так что считаю совет не корректным.
Ну как вариант, вы можете включить пуши и оповещения от сайта и видеть все обновления плагинов (как временный вариант)
оповещения могут приходить куда угодно, в telegram, discrod и тд.

на данный момент наша система обновлений и оповещений работает только так, мы обязательно ее переработаем, но это требует сильных архитектурных изменений, по этой причине это и занимает время.
 


ИП Кузьмык Даниил Павлович
(ИНН 784101059209, ОГРНИП 321784700227944)

Связь по Telegram: @mcdevs_bot

Заказ услуг
Пользовательское соглашение
Политика конфиденциальности
Помощь по сайту
Поддержка

DMCA.com Protection Status

Платежные шлюзы